#!/bin/sh
CWD=`pwd`
PKG=/tmp/package-pilot-link
rm -rf $PKG
mkdir -p $PKG

VERSION=0.11.8
ARCH=i486
BUILD=2

cd /tmp
rm -rf pilot-link-$VERSION
tar xjvf $CWD/pilot-link-$VERSION.tar.bz2
cd pilot-link-$VERSION
chown -R root.root .
CFLAGS="-O2 -march=i486 -mcpu=i686" \
./configure --prefix=/usr \
            --localstatedir=/var/lib \
            --program-prefix="" --program-suffix="" \
            i486-slackware-linux
make
make install DESTDIR=$PKG
chown -R root.bin $PKG/usr/bin
( cd $PKG
  find . | xargs file | grep "ELF 32-bit LSB executable" | grep 80386 | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
  find . | xargs file | grep "ELF 32-bit LSB shared object" | grep 80386 | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
strip -g $PKG/usr/lib/*.a
mkdir -p $PKG/usr/doc/pilot-link-$VERSION
cp -a ABOUT-NLS AUTHORS BUGS COPYING COPYING.LIB NEWS README TODO \
  $PKG/usr/doc/pilot-link-$VERSION
chmod 644 $PKG/usr/doc/pilot-link-$VERSION/*
gzip -9 $PKG/usr/man/man?/*.?
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat << EOF > $PKG/install/doinst.sh
if [ ! -r dev/pilot ]; then # pick a default
  ( cd dev ; ln -sf ttyS0 pilot )
fi
EOF

cd $PKG
makepkg -l y -c n /tmp/pilot-link-$VERSION-$ARCH-$BUILD.tgz